A-A+

“DedeCMS Error: (PHP 5.3 and above) Please set request_order”的解决方法

2015年03月15日 建站之旅

今天登录DedeCMS搭建的网站,发现无法打开登录页面,显示如下错误信息:

(PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P (recommended: 'CGP') in php.ini

后面有一个链接“more”,点击该链接打开DedeCMS官网对该问题的解释和解决方法:

原来是由于在PHP 5.3及以上的版本中增加了一个配置项目“request_order”,默认值为“GP”,这个存在一定的安全风险,所以我们DedeCMS建议用户将配置更改为“CGP”。具体修改方法为:

编辑PHP目录下的php.ini文件,将其中的request_order = "GP"修改为request_order = "CGP"即可。

但因为三好公民使用的是虚拟主机,所以无法自行修改php.ini,但是却可以在虚拟主机的控制面板中切换PHP版本,所以只好把PHP版本切换为低一级的5.2暂时解决了问题。

微信扫码
支付宝扫码
请打赏,这是对本文作者最实在的帮助和鼓励!
标签: